Connecting Multicast Islands with GRE

Multicast Receiver: 192.168.1.10/24Site 1 Router:
-ip multicast-routing
-MC Receiver interface: 192.168.1.1/24
-ip pim sparse-mode
-WAN interface: 172.31.254.2/30
-BGP ASN: 64512, redistribute connected
-ip pim rp-address 10.100.100.1
Service Provider:
-NO PIM / MULTICAST ROUTING
-Site 1 interface: 172.31.254.1/30
-DC interface: 172.31.254.5/30
-BGP ASN: 64513, redistribute connected
DC Edge Router:
-ip multicast-routing
-WAN interface: 172.31.254.6/30
-BGP ASN: 64514, redistribute connected
-DC RP interface: 10.255.1.1/30
-ip pim sparse-mode
-ip pim rp-address 10.100.100.1
-OSPF area 0, mutual BGP redistribution
DC RP Router:
-ip multicast-routing
-DC Edge interface: 10.255.1.2/30
-ip pim sparse-mode
-DC VLAN interface: 10.255.2.2/30
-ip pim sparse-mode
-Loopback1 interface: 10.100.100.1/32
-ip pim sparse-mode
-OSPF area 0
-ip pim rp-address 10.100.100.1
DC VLAN Router:
-ip multicast-routing
-DC RP interface: 10.255.2.1/30
-ip pim sparse-mode
-Multicast Sender interface: 10.1.1.1/24
-ip pim sparse-mode
-OSPF area 0
-ip pim rp-address 10.100.100.1
Multicast Sender: 10.1.1.10/24
MCsender# traceroute 192.168.1.10
Type escape sequence to abort.
Tracing the route to 192.168.1.10
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.1.1 1 msec 0 msec 0 msec
2 10.255.2.2 0 msec 1 msec 0 msec
3 10.255.1.1 1 msec 1 msec 0 msec
4 172.31.254.5 1 msec 0 msec 1 msec
5 172.31.254.2 1 msec 0 msec 1 msec
6 192.168.1.10 1 msec * 2 msec
DC-Edge(config)# interface e0/1
DC-Edge(config-int)# ip igmp join-group 239.1.2.3
DC-Edge# show ip mroute<output omitted>(*, 239.1.2.3), 00:00:31/00:02:28, RP 10.100.100.1, flags: SJPL
Incoming interface: Ethernet0/1, RPF nbr 10.255.1.2
Outgoing interface list: Null
DC-RP# show ip mroute(*, 239.1.2.3), 00:03:52/00:02:42, RP 10.100.100.1, flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0/0, Forward/Sparse, 00:03:52/00:02:42
MCsender# ping 239.1.2.3 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 239.1.2.3, timeout is 2 seconds:
Reply to request 0 from 10.255.1.1, 11 ms
Reply to request 1 from 10.255.1.1, 2 ms
Reply to request 2 from 10.255.1.1, 1 ms
Reply to request 3 from 10.255.1.1, 1 ms
Reply to request 4 from 10.255.1.1, 1 ms
DC-VLAN: show ip mroute(*, 239.1.2.3), 00:04:43/stopped, RP 10.100.100.1, flags: SPF
Incoming interface: Ethernet0/0, RPF nbr 10.255.2.2
Outgoing interface list: Null
(10.1.1.10, 239.1.2.3), 00:00:26/00:03:07, flags: FT
Incoming interface: Ethernet0/1, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0/0, Forward/Sparse, 00:00:26/00:03:05
MCreceiver(config)# interface e0/0
MCreceiver(config-int)# ip igmp join-group 239.1.2.3
Site 1 Router:interface tunnel 100
ip address 172.16.100.2 255.255.255.252
ip pim sparse-mode
tunnel source e0/0
tunnel destination 172.31.254.6
DC Edge Router:interface tunnel 100
ip address 172.16.100.1 255.255.255.252
ip pim sparse-mode
tunnel source e0/0
tunnel destination 172.31.254.2
MCsender# ping 239.1.2.3 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 239.1.2.3, timeout is 2 seconds:
Reply to request 0 from 10.255.1.1, 9 ms
Reply to request 1 from 10.255.1.1, 3 ms
Reply to request 2 from 10.255.1.1, 1 ms
Reply to request 3 from 10.255.1.1, 1 ms
Reply to request 4 from 10.255.1.1, 2 ms
Site1# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.100.1 Tunnel100 00:08:10/00:01:25 v2 1 / S P G
DC-VLAN# mtrace 10.1.1.1 192.168.1.10 239.1.2.3
Type escape sequence to abort.
Mtrace from 10.1.1.1 to 192.168.1.10 via group 239.1.2.3
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 192.168.1.10
-1 * 192.168.1.10 ==> 0.0.0.0 None Multicast disabled [default]
Site1(config)# ip mroute 10.100.100.1 255.255.255.255 172.16.100.1
MCsender# ping 239.1.2.3 repeat 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 239.1.2.3, timeout is 2 seconds:
Reply to request 0 from 10.255.1.1, 15 ms
Reply to request 0 from 192.168.1.10, 20 ms
Reply to request 1 from 10.255.1.1, 2 ms
Reply to request 1 from 192.168.1.10, 3 ms
DC-VLAN# mtrace 10.1.1.1 192.168.1.10 239.1.2.3
Type escape sequence to abort.
Mtrace from 10.1.1.1 to 192.168.1.10 via group 239.1.2.3
From source (?) to destination (?)
Querying full reverse path...
0 192.168.1.10
-1 172.16.100.2 ==> 172.16.100.2 PIM_MT [using shared tree]
-2 172.16.100.1 ==> 10.255.1.1 PIM [using shared tree]
-3 10.255.1.2 ==> 0.0.0.0 PIM_MT Reached RP/Core [using shared tree]
MCsender# traceroute 192.168.1.10
Type escape sequence to abort.
Tracing the route to 192.168.1.10
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.1.1 1 msec 0 msec 0 msec
2 10.255.2.2 1 msec 0 msec 0 msec
3 10.255.1.1 1 msec 0 msec 1 msec
4 172.31.254.5 0 msec 0 msec 1 msec
5 172.31.254.2 0 msec 1 msec 1 msec
6 192.168.1.10 1 msec * 2 msec
ip mroute 10.100.100.0 255.255.255.0 172.16.100.1
ip mroute 0.0.0.0 0.0.0.0 172.16.100.1

--

--

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store